API Service Unavailable

Incident Report for FinPro

Resolved

The API Service has been restored and is now operating normally.
Posted Jun 29, 2026 - 13:12 UTC

Investigating

Our monitoring detected that the API Service is currently unavailable. Our team has been notified and is investigating.
Posted Jun 29, 2026 - 13:11 UTC
This incident affected: APIs.